Dependency Convergence

Legend:
[Error]
At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of dependencies (NOD): 44
Number of unique artifacts (NOA): 64
Number of version-conflicting artifacts (NOC): 12
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA):
[Error]
 68 %
Ready for release (100% convergence and no SNAPSHOTS):
[Error]
 Error
You do not have 100% convergence.

Dependencies used in this project

commons-io:commons-io

[Error]
2.5
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-archiver:jar:3.5.0:compile
       \- (commons-io:commons-io:jar:2.5:compile - omitted for conflict with 2.6)

2.6
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    +- org.codehaus.plexus:plexus-io:jar:3.2.0:compile
    |  \- (commons-io:commons-io:jar:2.6:compile - omitted for conflict with 2.5)
    +- org.apache.maven.shared:maven-filtering:jar:3.2.0:compile
    |  \- (commons-io:commons-io:jar:2.6:compile - omitted for conflict with 2.5)
    +- org.apache.maven.shared:maven-shared-utils:jar:3.3.3:compile
    |  \- (commons-io:commons-io:jar:2.6:compile - omitted for conflict with 2.5)
    \- commons-io:commons-io:jar:2.6:test (scope not updated to compile)

junit:junit

[Error]
3.8.2
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven.shared:maven-verifier:jar:1.6:test
       \- (junit:junit:jar:3.8.2:test - omitted for conflict with 4.13.1)

4.13.1
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- junit:junit:jar:4.13.1:test

org.apache.maven.shared:maven-shared-utils

[Error]
0.8
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven.shared:maven-verifier:jar:1.6:test
       \- (org.apache.maven.shared:maven-shared-utils:jar:0.8:test - omitted for conflict with 3.3.3)

3.2.1
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-archiver:jar:3.5.0:compile
       \- (org.apache.maven.shared:maven-shared-utils:jar:3.2.1:compile - omitted for conflict with 3.3.3)

3.3.3
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    +- org.apache.maven.shared:maven-filtering:jar:3.2.0:compile
    |  \- (org.apache.maven.shared:maven-shared-utils:jar:3.3.3:compile - omitted for conflict with 3.2.1)
    \- org.apache.maven.shared:maven-shared-utils:jar:3.3.3:compile

org.apache.maven:maven-artifact

[Error]
3.0
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    +- org.apache.maven:maven-archiver:jar:3.5.0:compile
    |  \- (org.apache.maven:maven-artifact:jar:3.0:compile - omitted for conflict with 3.1.1)
    \- org.apache.maven.plugin-tools:maven-plugin-annotations:jar:3.6.0:provided
       \- (org.apache.maven:maven-artifact:jar:3.0:provided - omitted for conflict with 3.1.1)

3.1.1
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    +- org.apache.maven:maven-plugin-api:jar:3.1.1:compile
    |  \- (org.apache.maven:maven-artifact:jar:3.1.1:compile - omitted for duplicate)
    +- org.apache.maven:maven-artifact:jar:3.1.1:compile
    \- org.apache.maven:maven-core:jar:3.1.1:compile
       \- (org.apache.maven:maven-artifact:jar:3.1.1:compile - omitted for duplicate)

org.apache.maven:maven-core

[Error]
3.0
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    +- org.apache.maven:maven-archiver:jar:3.5.0:compile
    |  \- (org.apache.maven:maven-core:jar:3.0:compile - omitted for conflict with 3.1.1)
    \- org.apache.maven.shared:maven-mapping:jar:3.0.0:compile
       \- (org.apache.maven:maven-core:jar:3.0:compile - omitted for conflict with 3.1.1)

3.1.0
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven.shared:maven-filtering:jar:3.2.0:compile
       \- (org.apache.maven:maven-core:jar:3.1.0:compile - omitted for conflict with 3.1.1)

3.1.1
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-core:jar:3.1.1:compile

org.apache.maven:maven-model

[Error]
3.0
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-archiver:jar:3.5.0:compile
       \- (org.apache.maven:maven-model:jar:3.0:compile - omitted for conflict with 3.1.1)

3.1.0
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven.shared:maven-filtering:jar:3.2.0:compile
       \- (org.apache.maven:maven-model:jar:3.1.0:compile - omitted for conflict with 3.1.1)

3.1.1
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    +- org.apache.maven:maven-plugin-api:jar:3.1.1:compile
    |  \- org.apache.maven:maven-model:jar:3.1.1:compile
    \- org.apache.maven:maven-core:jar:3.1.1:compile
       +- (org.apache.maven:maven-model:jar:3.1.1:compile - omitted for duplicate)
       +- org.apache.maven:maven-model-builder:jar:3.1.1:compile
       |  \- (org.apache.maven:maven-model:jar:3.1.1:compile - omitted for duplicate)
       \- org.apache.maven:maven-aether-provider:jar:3.1.1:compile
          \- (org.apache.maven:maven-model:jar:3.1.1:compile - omitted for duplicate)

org.apache.maven:maven-settings

[Error]
3.1.0
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven.shared:maven-filtering:jar:3.2.0:compile
       \- (org.apache.maven:maven-settings:jar:3.1.0:compile - omitted for conflict with 3.1.1)

3.1.1
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-core:jar:3.1.1:compile
       +- org.apache.maven:maven-settings:jar:3.1.1:compile
       \- org.apache.maven:maven-settings-builder:jar:3.1.1:compile
          \- (org.apache.maven:maven-settings:jar:3.1.1:compile - omitted for duplicate)

org.codehaus.plexus:plexus-archiver

[Error]
4.2.0
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-archiver:jar:3.5.0:compile
       \- (org.codehaus.plexus:plexus-archiver:jar:4.2.0:compile - omitted for conflict with 4.2.1)

4.2.1
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.codehaus.plexus:plexus-archiver:jar:4.2.1:compile

org.codehaus.plexus:plexus-classworlds

[Error]
2.4
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-plugin-api:jar:3.1.1:compile
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.0.0.M5:compile
          \- (org.codehaus.plexus:plexus-classworlds:jar:2.4:compile - omitted for conflict with 2.5.1)

2.5.1
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-core:jar:3.1.1:compile
       \- org.codehaus.plexus:plexus-classworlds:jar:2.5.1:compile

org.codehaus.plexus:plexus-interpolation

[Error]
1.19
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-core:jar:3.1.1:compile
       +- org.apache.maven:maven-settings-builder:jar:3.1.1:compile
       |  \- (org.codehaus.plexus:plexus-interpolation:jar:1.19:compile - omitted for duplicate)
       +- org.apache.maven:maven-model-builder:jar:3.1.1:compile
       |  \- (org.codehaus.plexus:plexus-interpolation:jar:1.19:compile - omitted for duplicate)
       \- (org.codehaus.plexus:plexus-interpolation:jar:1.19:compile - omitted for conflict with 1.26)

1.21
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven.shared:maven-mapping:jar:3.0.0:compile
       \- (org.codehaus.plexus:plexus-interpolation:jar:1.21:compile - omitted for conflict with 1.26)

1.25
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-archiver:jar:3.5.0:compile
       \- (org.codehaus.plexus:plexus-interpolation:jar:1.25:compile - omitted for conflict with 1.19)

1.26
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    +- org.apache.maven.shared:maven-filtering:jar:3.2.0:compile
    |  \- (org.codehaus.plexus:plexus-interpolation:jar:1.26:compile - omitted for conflict with 1.19)
    \- org.codehaus.plexus:plexus-interpolation:jar:1.26:compile

org.codehaus.plexus:plexus-utils

[Error]
1.5.5
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-core:jar:3.1.1:compile
       \- org.sonatype.plexus:plexus-sec-dispatcher:jar:1.3:compile
          \- (org.codehaus.plexus:plexus-utils:jar:1.5.5:compile - omitted for conflict with 3.0.15)

1.5.8
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven.shared:maven-filtering:jar:3.2.0:compile
       \- org.sonatype.plexus:plexus-build-api:jar:0.0.7:compile
          \- (org.codehaus.plexus:plexus-utils:jar:1.5.8:compile - omitted for conflict with 3.3.0)

2.1
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven:maven-plugin-api:jar:3.1.1:compile
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.0.0.M5:compile
          \- (org.codehaus.plexus:plexus-utils:jar:2.1:compile - omitted for conflict with 3.0.15)

3.0.15
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    +- org.apache.maven:maven-plugin-api:jar:3.1.1:compile
    |  \- org.apache.maven:maven-model:jar:3.1.1:compile
    |     \- (org.codehaus.plexus:plexus-utils:jar:3.0.15:compile - omitted for duplicate)
    +- org.apache.maven:maven-artifact:jar:3.1.1:compile
    |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.15:compile - omitted for conflict with 3.3.0)
    \- org.apache.maven:maven-core:jar:3.1.1:compile
       +- org.apache.maven:maven-settings:jar:3.1.1:compile
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.15:compile - omitted for duplicate)
       +- org.apache.maven:maven-settings-builder:jar:3.1.1:compile
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.15:compile - omitted for duplicate)
       +- org.apache.maven:maven-repository-metadata:jar:3.1.1:compile
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.15:compile - omitted for duplicate)
       +- org.apache.maven:maven-model-builder:jar:3.1.1:compile
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.15:compile - omitted for duplicate)
       +- org.apache.maven:maven-aether-provider:jar:3.1.1:compile
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.15:compile - omitted for duplicate)
       \- (org.codehaus.plexus:plexus-utils:jar:3.0.15:compile - omitted for duplicate)

3.3.0
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    +- org.apache.maven:maven-archiver:jar:3.5.0:compile
    |  \- (org.codehaus.plexus:plexus-utils:jar:3.3.0:compile - omitted for conflict with 3.0.15)
    +- org.codehaus.plexus:plexus-archiver:jar:4.2.1:compile
    |  \- (org.codehaus.plexus:plexus-utils:jar:3.3.0:compile - omitted for conflict with 3.0.15)
    +- org.codehaus.plexus:plexus-utils:jar:3.3.0:compile
    +- org.codehaus.plexus:plexus-io:jar:3.2.0:compile
    |  \- (org.codehaus.plexus:plexus-utils:jar:3.3.0:compile - omitted for duplicate)
    \- org.apache.maven.shared:maven-filtering:jar:3.2.0:compile
       \- (org.codehaus.plexus:plexus-utils:jar:3.3.0:compile - omitted for duplicate)

org.eclipse.sisu:org.eclipse.sisu.plexus

[Error]
0.0.0.M2a
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    \- org.apache.maven.shared:maven-filtering:jar:3.2.0:compile
       \- (org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.0.0.M2a:compile - omitted for conflict with 0.0.0.M5)

0.0.0.M5
    org.apache.maven.plugins:maven-ear-plugin:maven-plugin:3.2.0
    +- org.apache.maven:maven-plugin-api:jar:3.1.1:compile
    |  \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.0.0.M5:compile
    \- org.apache.maven:maven-core:jar:3.1.1:compile
       \- (org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.0.0.M5:compile - omitted for duplicate)


无码av高清毛片在线看_日本一级特黄大片_日本毛片免费视频观看_免费v片在线观看网站